Welcome, Guest!!
follow us on... Facebook twitter rss

Author Topic: FIX - Program Files permissions issue SOLVED!  (Read 50025 times)

Offline SnowHow

  • Hero Member
  • *****
  • Posts: 946
  • Karma: +16/-0
  • A-1 Radio - The Variety Channel
    • A-1 Radio - The Variety Channel
FIX - Program Files permissions issue SOLVED!
« on: August 18, 2012, 05:31:48 PM »
Coming from a Windows 2000/XP world into Windows 7, I found the security restrictions intolerable. That much security is just nonsense, so I sat down, rolled up my sleeves and set out to regain control of my computer. It took me about an hour, but I figured it out. I wrote down everything I did so I could share with my fellow broadcasters. This should solve all the issues of RDJ not being able to write to now_playing.txt, MySQL not wanting to install right and a multitude of other issues that have been plaguing RDJ users wrestling with Windows 7 trying to get things working. You may want to copy/paste these instructions into Notepad and print it out. This procedure requires two restarts.

This is how I did it:

1) Turn off UAC (User Account Control)

Before you can do anything, you must turn off the UAC, or you will be locked out of the following steps.

1) Start -> Settings -> Control Panel -> User Accounts
2) Click "Change User Account Control Settings"
3) Move slider all the way down to "Never Notify"
4) Reboot

2) Take Ownership

Yes take ownership. Even though you are logged on as an Administrator, you can't change files that don't belong to you. The Program Files folder is set to the Trusted Installer group and the Administrator doesn't have the rights to change anything. So now we have to claim all the files and folders.

1) Open Windows Explorer
2) R-Click on Program Files -> Properties -> Security Tab
3) Click Advanced -> Owner
4) Click Edit
5) Select Administrators -> Put a checkmark in Replace owner on subcontainers & objects -> Apply
6) Wait a while.....
7) When it finishes, Click OK on all boxes to close everything

3) Fix Permissions

Now that you own the files, you have to give yourself permission to modify them

1) R-Click on Program Files -> Properties -> Security Tab
2) Click Advanced -> Change Permission
3) Select Administrators (any entry) -> Edit
4) Change the Apply To drop down box to This Folder, Subfolder & Files
5) Put check in Full Control under Allow column -> OK -> Apply
6) Wait some more.....
7) When it finishes, the dialog boxes may hide behind the Explorer window. Minimize it and click OK on all the the dialog boxes
8.) Reboot

Hello full control! Oh Glory!  :angel:

Hope this helps!



  • Guest
Re: FIX - Program Files permissions issue SOLVED!
« Reply #1 on: August 18, 2012, 05:36:28 PM »
Thank you SnowHow Topic set sticky !!!