Author Topic: RadioDJ constantly trying to connect to port 8000  (Read 689 times)

qcindie

  • Jr. Member

  • Offline
  • **
  • 68
    • QCIndie
RadioDJ constantly trying to connect to port 8000
« on: September 19, 2019, 05:37:53 AM »
Hi everyone,

I'm running a Windows Server 2012 VPS with the Shoutcast DNAS 2.6 Server installed, and RadioDJ 1.8.2 with the Streamer Plugin. I don't use port 8000, but for whatever reason, RadioDJ is *constantly* trying to connect to it with
ports in the 40000-50000 range. Here's what it looks like:

Resource Monitor:



Shoutcast DNAS:



Why is this happening? Is something incorrectly set up? Thanks for your help.

stevewa

  • Hero Member

  • Offline
  • *****
  • 1065
    • RadioDJ Remote Support Link to Pay for Help
Re: RadioDJ constantly trying to connect to port 8000
« Reply #1 on: September 19, 2019, 04:06:02 PM »
what is the remote address?
good use of imgur!
RadioDJ Remote Support Link to Pay For Personal Help: https://www.paypal.com/donate/?hosted_button_id=8RMWTFAWCX7WS

qcindie

  • Jr. Member

  • Offline
  • **
  • 68
    • QCIndie
Re: RadioDJ constantly trying to connect to port 8000
« Reply #2 on: September 19, 2019, 04:55:48 PM »
It's 127.0.0.1, it runs on the VPS. The one thing I haven't tried is restarting RadioDJ, but I want less listeners when I try that. Thanks for your help!

DJ Garybaldy

  • Global Moderator
  • Hero Member

  • Offline
  • *****
  • 4929
  • Personal Text
    Don't Shoot! I'm only the Moderator
    • DJ Garybaldy Blog
Re: RadioDJ constantly trying to connect to port 8000
« Reply #3 on: September 19, 2019, 05:08:08 PM »
Bear in mind the streamer plugin was basically a concept, as in Marius coded it because he could at the time. It was never really intended for full time use by busy stations

Its not been supported for some time now. Is there another option you could use to test with... I know not all solutions work on a VPS.


If its interfering then its probably a good idea to find another option.
Worlds Biggest Fan of RadioDJ

RadioDJ is my FAVOURITE piece of radio playout software EVER

https://djgarybaldy.blogspot.com/search?q=radiodj

Install RadioDJ: https://djgarybaldy.blogspot.com/2020/08/how-to-install-radiodj-free-radio.html

paypal.me/djgarybaldy

qcindie

  • Jr. Member

  • Offline
  • **
  • 68
    • QCIndie
Re: RadioDJ constantly trying to connect to port 8000
« Reply #4 on: September 19, 2019, 05:12:36 PM »
Yeah, I could never get the standalone streamers to work properly on a VPS, and it’s the primary reason I haven’t upgraded to RadioDJ v2. It’s not affecting anything, I’m just wondering what’s going on. Thanks for your help!

stevewa

  • Hero Member

  • Offline
  • *****
  • 1065
    • RadioDJ Remote Support Link to Pay for Help
Re: RadioDJ constantly trying to connect to port 8000
« Reply #5 on: September 19, 2019, 06:22:12 PM »
Shoutcast typically uses port 8000 & 8001 for source incoming connections, so it’s most likely The RDJ streamer doing that.


But also notice the red lines error in your DNAs log, something else is trying to hit those ports as an input source to DNas , so if there is a config in the rdj streamer, look there...
RadioDJ Remote Support Link to Pay For Personal Help: https://www.paypal.com/donate/?hosted_button_id=8RMWTFAWCX7WS

qcindie

  • Jr. Member

  • Offline
  • **
  • 68
    • QCIndie
Re: RadioDJ constantly trying to connect to port 8000
« Reply #6 on: September 19, 2019, 08:01:52 PM »
Hey guys,

So it turns out the problem was the Streamer plugin, specifically the reconnect option. I set it from 10 seconds to 0, restarted RadioDJ and the problem went away. Thanks for your help!