RadioDJ - Free Radio Automation Software Forum

Not loading correct track duration

Offline Frank

Not loading correct track duration
« on: February 20, 2020, 10:46:41 PM »
Hello, I am having a problem with RadioDJ not reconizing the correct duration of a file. My track length is 58:44 but it is showing to be 58:37 (and is cutting the last 7 seconds off). I have tried it on two different computers (one at my house and one at our studios) and both are cutting the end off.    I've never had this problem before (that I know of) after this started, I tried importing another shorter track and the same thing happend (real length was 1:57 but all RadioDJ saw was 1:53). The only thing I can think of is that both tracks were produced in Adobe Audition, one was exported in the .mp3 format (the longer one) and one in .wav.  This is a weekly program and my end goal would be for it to be loaded into the Aux Player using the "Play Newest File from Folder" option.

FYI: This is happening on both the track importer and with the Aux Player and cannot be fixed in the CUE settings although the CUE shows it to be the correct length.

Please anwser if you have any ideas, this is happening to a program that we are planning to start airing this Saturday.

Thanks so much in advance.

Offline DJ Garybaldy

  • *****
  • 3998
  • Never Get Angry At the Stupid People (Erasure)
    • DJ Garybaldy
Re: Not loading correct track duration
« Reply #1 on: February 20, 2020, 11:23:31 PM »
Is the file CBR or VBR? If its VBR you need select variable duration file as the track type (?)
USER of RadioDJ since 2010

Useful RadioDJ information : https://djgarybaldy.co.uk/category/radiodj/

I cannot give help and support via Private message!

I'm not as scary as I look Honest!

My little pet project: https://t.co/YyVaPOBYBK

Offline Frank

Re: Not loading correct track duration
« Reply #2 on: February 20, 2020, 11:54:02 PM »
Is the file CBR or VBR? If its VBR you need select variable duration file as the track type (?)
.
Just dual checked thru Gspot and the 58:44 program is CBR and the other one is a wav file (PCM so it can't be VBR, at least I don't think it can be).

Offline DJ Garybaldy

  • *****
  • 3998
  • Never Get Angry At the Stupid People (Erasure)
    • DJ Garybaldy
Re: Not loading correct track duration
« Reply #3 on: February 21, 2020, 12:10:58 AM »
Which version(s) is this happening on? Are there any clues in the Windows error logs? What OS are you on etc....
USER of RadioDJ since 2010

Useful RadioDJ information : https://djgarybaldy.co.uk/category/radiodj/

I cannot give help and support via Private message!

I'm not as scary as I look Honest!

My little pet project: https://t.co/YyVaPOBYBK

Offline Frank

Re: Not loading correct track duration
« Reply #4 on: February 21, 2020, 12:46:16 AM »
Which version(s) is this happening on? Are there any clues in the Windows error logs? What OS are you on etc....
Home Computer:
RadioDJ: 2.0.0.6
OS: Windows 10
CPU: Intel Xeon E5-2660 8-Core @2.20
Ram: 64 GB
SSD: Samsung 840 EVO 500GB
Audio Device: Zoom R16 and AMD sound via HDMI (thru the video card)
Windows Errors: None found (only errors I'm having are DCOM Server: AcrobatNotifcationClient errors and I don't think RadioDJ uses that)

Studio Computer:
RadioDJ: 2.0.0.3
OS: Windows 8.1
CPU: Intel Celeron J1800 2-Core @ 2.41
Ram: 4 GB
HDD: SEAGATE Barracuda 500GB @ 7200RPM
Sound Device: Behringer UMC 404HD
Windows Errors: Didn't check them because I'm veiwing it remotely and it is running a LPFM station and is VERY touchy (I don't want to break it and then have to go to the studio to fix it).
« Last Edit: February 21, 2020, 12:55:14 AM by Frank »

Offline DJ Garybaldy

  • *****
  • 3998
  • Never Get Angry At the Stupid People (Erasure)
    • DJ Garybaldy
Re: Not loading correct track duration
« Reply #5 on: February 21, 2020, 01:21:56 AM »
Are you running MySQL or MariaDB? Not quite sure what your issue could be maybe Marius will  come up with something. Its a strange problem.
USER of RadioDJ since 2010

Useful RadioDJ information : https://djgarybaldy.co.uk/category/radiodj/

I cannot give help and support via Private message!

I'm not as scary as I look Honest!

My little pet project: https://t.co/YyVaPOBYBK

Offline Frank

Re: Not loading correct track duration
« Reply #6 on: February 21, 2020, 02:13:55 AM »
MySQL.  I just tried importing a WAV track that was not exported by Audition and had the same problem (I think it has been imported by Audition in the past).
« Last Edit: February 21, 2020, 03:06:22 AM by Frank »

Offline Frank

Re: Not loading correct track duration
« Reply #7 on: February 21, 2020, 03:47:36 AM »
Ok, a couple of corrections to my original post.  I just tried editing the CUE again and it updated the track to the correct time  :bash: .  However, it still is cutting off the end when I import it for the first time or load it in the Aux Players (I think the Auto-Cue is doing that). This is making it impossible for me to use the "Play Newest Track for Folder" because it cuts off the end of the program unless I manually import the track and edit the Cue.  Also (unlike I said earlier), I've found the rest of the audio files on my home computer (not sure about the studio one) have the same problem of being cut off two soon.  Is there a way to shut off the Auto-Cueing at least on the Aux Player?  Also, is there a way to manually input the ending and next start times in the Cue Editor (I can only get the slider to 58:40 not to 58:44)?  So sorry for not relizing this earlier, I really hope this has not been a big problem for you. :(