• Welcome to RadioDJ - Free Radio Automation Software Forum. Please log in or sign up.

Database setup utility errors

Started by DJ Philouee, November 18, 2023, 12:15:59 AM

DJ Philouee

I'm trying to install a backup database from my backup server, to a new server.  The old server fried, but I had a complete backup on the backup server which is presently running.  I am trying to run the database setup utility, but get an error (Microsoft .net framework(unhandled exception has occured."Object cannot be cast from DBNull to other types)  I hit continue, install the Database.  My SQL server is running, however I get the same error, and The backup database file I copy and pasted from the backup server will not install using restore database!  Please advise?  This is for Radio DJ version  Do I need to download a different flavor of .Net Framework?  I would upgrade to version 2, but I have several vst plugins that go along with the old version. Thanks for any suggestions on fixing this.  Philip L George

DJ Philouee

Okay, so no help at all from anyone!  Anyway, I figured it out myself if anyone is interested. :'(


R.T.F.M. means to me, Read The Fantastic Messages.
Einstein says: Make things simple, but don't make simple things simpler! (wise) this is just my life lesson you know.

I don't do drugs ( ͡° ͜ʖ ͡°)
The Radiodj tutorials site is now managed by Domstad radio .nl still  Just in English

DJ Philouee

After researching the issue, it looks like you have to make sure the version of Maria DB SQL server software is the same one you used when you installed RDJ!  I simply uninstalled Maria DB, and reinstalled an older flavor of Maria DB.  Everything works, almost.  The Database installed, and the error disappeared!  The program runs now, with the rotations, events, and the mp3's play!  Unfortunately, none of the sound processing plugins run, and I'm getting an error about one of the dll's(Dynamic link library) not being found, although it's in the plugin folder.  This was the only reason I stuck with the older version for now.  Anyway, I will be investigating this error also. Let's see, uninstall, and re-install DSP, and VST plugins and add-ons maybe?  Suggestions would be appreciated!  Thanks! :)

DJ Philouee

Fixed it!  I needed the correct version of Microsoft Visual C++ installed on the pc!


Those mistakes probably won't show up in your version because it's too old. Reinstalling the plugins might be an option to try. It was the solution I needed.


Verify that the instance name is correct and that SQL Server is configured to allow remote connections.