• Welcome to RadioDJ - Free Radio Automation Software Forum. Please log in or sign up.

Drag And Drop Not Working.

Started by charmingnathan, April 02, 2024, 03:55:29 AM


Dear All,

There is not much information I am able to offer you with this issue.

Have recently upgraded, as you may have observed from other posts from to, with some difficulty (will post the 'resolution to this at some point), but Drag and Drop is not working - have four instances of RadioDJ running, ahd have tried them.

When attempting to drag tracks from Widows Explorer to the first 'page' of RadioDJ, where Categories are shown, along with Sub Titiles, nothing happens.

Drag the tracks into this area, with Music, the Category, and Sub Category selected, but nothing happens, no error message, log, etc., the tracks are not added.

Any ideas what this could be, please?

Thanks for your help



When posting the above message, made a new thread, as I assumed this was not connected to the importing Database issue, that is detailed elsewhere on this forum, however not so sure?!

Have checked this issue in and still persists, without any importing of Music or Database, can only add Music by manually importing, i.e. within Tracks Manager, and Import Folder.

However, advised above there were no error messages, and this is correct as far as the Exception Log is concerned, but not Applications,  witthin Event Viewer! Does the following help diagnose the issue?

Database Insert Error: Unknown column 'bs1770' in 'field list' (INSERT IGNORE INTO `songs` SET `path` = 'C:\\Users\\Nathan\\Music\\Arctic Monkeys - The Car\\Arctic Monkeys - The Car 21102022\\cleaned\\Arctic Monkeys - Jet Skis On The Moat (Official Audio).mp3', `enabled` = 1, `date_added` = NOW(), `start_date` = '2002-01-01 00:00:01', `end_date` = '2002-01-01 00:00:01', `startEvent` = '0', `endEvent` = '0', `play_limit` = '0', `limit_action` = '0', `song_type` = '0', `id_subcat` = '3', `id_genre` = '32', `weight` = 50, `duration` = 184.993424036281, `original_duration` = 185.026893424036, `cue_times` = '&sta=9.0702947845805E-05&xta=184.940566893424&end=184.993514739229&fin=0&fou=0.0529478458049937', `precise_cue` = '0', `fade_type` = '0', `start_type` = '0', `end_type` = '0', `mix_type` = '0', `mood` = '', `gender` = '', `lang` = '', `rating` = '0', `loudness` = '1', `bs1770` = '0', `artist` = 'Arctic Monkeys', `associated_artists` = '', `original_artist` = '', `title` = 'Jet Skis on the Moat', `album` = 'The Car', `composer` = '', `label` = '', `year` = '2022', `track_no` = '0', `disc_no` = '0', `publisher` = 'Domino; Domino', `copyright` = '', `isrc` = '', `bpm` = '0', `comments` = '', `sweepers` = '', `image` = 'Arctic Monkeys - Jet Skis On The Moat (Official Audio).jpg', `buy_link` = '', `url1` = '', `url2` = '', `overlay` = '0', `originalmetadata` = '0' ;)
Thanks for any help you are able to offer.


This appears to be a database issue. Check your database and see if column "bs1770" is in it. Should be column 34 after "loudness".

If it is not in the database, check the RadioDJ/Setup/Sql folder to see if there is a file to insert this column. In my case, there is an update command in the "update to" file that would do this. Execute this command in your Mysql database.

As always, ensure you backup your current database before you make any changes.

Hope this helps.


Thanks for your reply Kiwi.

The word "loudness" appeared to be in the correct place, but used the update files anyway, received an error with the second, stating (basically) a double enstry for bs1770?!

Tried Drag and Drop on both versions, still not working, and no error messages in either Exceptions Log, or Event Viewer.



Have carried out some more work on this issue, but not sure how much the following will help any troubleshooting?!

Decided to install a fresh copy of with a new Database, and drag and drop worked fine, even advising that I hadn't selected Categories the first time I tried to drag and drop!

Then I tried 2.0.3..8, again with a fresh Database, no error message when I tried to drag and drop, but nothiing happened.

Used the update file, and while this did install correctly, made no difference.

There are no error messages, either in the Exceptions Log, or the Events Log.

Wonder if this is just down to a Widows 7 issue, and that is more compatible with the O.S., than the other versions?!