Author Topic: Rotation plays too many tracks  (Read 1693 times)

antonlamers

  • Full Member

  • Offline
  • ***
  • 103
Rotation plays too many tracks
« on: November 15, 2015, 07:52:20 PM »
Hi,

My rotations does have 19 songs.
When rdj load a rotation there are about 32 songs in the main playlist screen.
THE problem now is. When the teasers is comming up. It takes also songs that are not playing this hour because 32 songs is too many for one hour.
What can I do that rdj load the 19 songs from my rotation and not more.

Anton

Capt_Fuzzy

  • Hero Member

  • Offline
  • *****
  • 1078
  • Personal Text
    "Quiet numbskulls, I'm broadcasting!" ~ Moe Howard
    • WVRR - Ridgerunners Radio
Re: Rotation plays too many tracks
« Reply #1 on: November 15, 2015, 08:45:10 PM »
Sounds like you are running in full "auto mode" which means that RadioDJ will attempt to keep the playback que full at all times, that way you avoid "dead air".
The only way to stop that is to switch to manual, turn off "AutoDJ" and "Automated" and you will have more control over what's loaded and played. If you are leaving your station unattended, then turn those back on or you will be broadcasting dead air before long...  ;D
Steve 'Capt Fuzzy' Wade
Proud & Satisfied "Long-term" RadioDJ User
(Currently making the transition to v2)

WVRR - Ridgerunners Radio
The best mix of your favorites!

Valdis

  • Hero Member

  • Offline
  • *****
  • 562
  • Personal Text
    Radio is a mental condition
    • home
Re: Rotation plays too many tracks
« Reply #2 on: November 16, 2015, 09:50:09 AM »
Hi Anton,

You can control for how many tracks teasers are generated. Set the number to 19 or less and your issue should be solved.

RadioDJ will load more tracks using rotation every time the main playlist (queue) contains less songs than entries in active rotation. You can trick RadioDJ by loading a dummy rotation that contains only one entry after AutoDJ has loaded all tracks from the intended rotation. That can be done in a single event.
I am, therefore I think.
I design and develop web apps, and have created few RadioDJ plugins - https://axellence.lv/downloads/

antonlamers

  • Full Member

  • Offline
  • ***
  • 103
Re: Rotation plays too many tracks
« Reply #3 on: November 27, 2015, 04:39:00 PM »
Thanks for the answers

plauri

  • Hero Member

  • Offline
  • *****
  • 1558
    • Funky Corner Radio
Re: Rotation plays too many tracks
« Reply #4 on: November 28, 2015, 01:58:43 AM »
Hi Valdis,
can you be more specific on how to load a dummy rotation that contains only one entry after AutoDJ has loaded all tracks from the intended rotation? Do I have to load an event (not a track) at the end of my list rotation? And what kind of event? Thanks
Funky Corner Radio
http://www.funkycorner.radio
https://www.funkycorner.it
http://www.radiofunkycorner.com

Valdis

  • Hero Member

  • Offline
  • *****
  • 562
  • Personal Text
    Radio is a mental condition
    • home
Re: Rotation plays too many tracks
« Reply #5 on: December 02, 2015, 07:04:02 PM »
Hi Valdis,
can you be more specific on how to load a dummy rotation that contains only one entry after AutoDJ has loaded all tracks from the intended rotation? Do I have to load an event (not a track) at the end of my list rotation? And what kind of event? Thanks

You can load a rotation using events. It would work as playlist event only if it was loaded as first entry in playlist. Better schedule it in the same event but add few seconds wait before that.
You may as well turn off AutoDJ after the intended rotation has loaded first batch of tracks. That also requires short pause after loading rotation and clearing playlist.
But you have to be absolutely sure that rotation loads enough tracks to fill hour.


I am, therefore I think.
I design and develop web apps, and have created few RadioDJ plugins - https://axellence.lv/downloads/