Author Topic: Streamer plugin SHOUTcast stream ID bug  (Read 2747 times)

Valdis

  • Hero Member

  • Offline
  • *****
  • 562
  • Personal Text
    Radio is a mental condition
    • home
Streamer plugin SHOUTcast stream ID bug
« on: August 18, 2016, 04:56:11 PM »
There appears to be a bug in UI of streamer plugin. When user tries to set "Stream ID" to number greater that 100000, the input field resets to the max allowed number.
This was discovered by MishmashLV, who contacted my in PM to ask for help. His stream ID number is greater than 772000 and he can't use the streamer UI to set the ID.

If anyone else is encountering this issue, there is a workaround while Marius fix the plugin - edit "Plugin_Encoders_List.xml" and set your stream ID there, then restart RadioDJ.

Update: According to Stream Configuration section in SHOUTcast server documentation:
Quote
streamid : Specify the numerical identifier of the stream for control or referencing the stream configuration. This can only be a numeric value from 1 to 2147483647.

That upper limit looks like 2^31 which is maximum value of signed 32-bit integer and corresponds to Int32.MinValue in .Net.
I am, therefore I think.
I design and develop web apps, and have created few RadioDJ plugins - https://axellence.lv/downloads/

baken1925

  • New User

  • Offline
  • *
  • 28
Re: Streamer plugin SHOUTcast stream ID bug
« Reply #1 on: September 10, 2016, 01:04:31 AM »
I have this exact same issue trying to connect to shoutcast.com I can connect no problem using BUTT but not in radiodj. I get the green light enabled but no further. When I try to put in my stream ID it defaults back to the 100000.

oxcom

  • New User

  • Offline
  • *
  • 4
Re: Streamer plugin SHOUTcast stream ID bug
« Reply #2 on: December 28, 2016, 10:47:26 PM »
Is there a status on this. I am trying to use RadioDJ to connect to ShoutCast streaming service. Using the work around the light turns green in the plugin, but I cannot find my station in the SC directory. It appears that it isn't truly connected.

plauri

  • Hero Member

  • Offline
  • *****
  • 1573
    • Funky Corner Radio
Re: Streamer plugin SHOUTcast stream ID bug
« Reply #3 on: December 29, 2016, 11:52:02 PM »
Hi oxcom,
I think you need to make your streaming public. You have to click on the "Admin" button in your Centova panel on the left, in the new page you have to log in the Shoutcast server: use "admin" as login and the password you use to connect to your Centova panel. Then in the new page you have to configure your Authhash. Click on it and fill all the fields, then update it. After a few minutes you'll see your streaming listed in the Shoutcast directory.
Funky Corner Radio
http://www.funkycorner.radio
https://www.funkycorner.it
http://www.radiofunkycorner.com